Error after attempting SSL tutorial

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Error after attempting SSL tutorial

nybras
I was attempting the SSL tutorial and when I went to restart RabbitMQ I got the following:

Error: unable to connect to node rabbit@h2093796: nodedown

DIAGNOSTICS
===========

nodes in question: [rabbit@h2093796]

hosts, their running nodes and ports:
- h2093796: [{rabbitmqctl14922,34865}]

current node details:
- node name: rabbitmqctl14922@h2093796
- home dir: /var/lib/rabbitmq
- cookie hash: cXy70uavVk97ENIqkfUwBQ==


I panicked big time and tried to uninstall and then re-install but still have the same problem. I really haven't got a clue what to do..

Your help would be most appreciated!
Reply | Threaded
Open this post in threaded view
|

Re: Error after attempting SSL tutorial

nybras
I've also got this in my .log

=INFO REPORT==== 19-Mar-2013::21:39:04 ===
Halting Erlang VM

and this:

ERROR: node with name "rabbit" already running on "h2093796"
Reply | Threaded
Open this post in threaded view
|

Re: Error after attempting SSL tutorial

Jerry Kuch
I was just going to ask if you already had one running.

Check your machine for processes with beam in the process name, and command lines where lots of rabbity stuff appears, using 'ps'.  Then kill the stragglers if you've got some that for some reason aren't responding to the proper shutdown method (the most common causes of which are running one thing or another as the wrong user).

On Tue, Mar 19, 2013 at 3:05 PM, nybras <[hidden email]> wrote:
I've also got this in my .log

=INFO REPORT==== 19-Mar-2013::21:39:04 ===
Halting Erlang VM

and this:

ERROR: node with name "rabbit" already running on "h2093796"



--
View this message in context: http://rabbitmq.1065348.n5.nabble.com/Error-after-attempting-SSL-tutorial-tp25565p25571.html
Sent from the RabbitMQ mailing list archive at Nabble.com.
_______________________________________________
rabbitmq-discuss mailing list
[hidden email]
https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss


_______________________________________________
rabbitmq-discuss mailing list
[hidden email]
https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
Reply | Threaded
Open this post in threaded view
|

Re: Error after attempting SSL tutorial

nybras
I've tried killing the processes using PS but still not working. What's beam though?
Reply | Threaded
Open this post in threaded view
|

Re: Error after attempting SSL tutorial

nybras
In my erl_crash.dump I'm getting: init terminating in do_boot ()
Reply | Threaded
Open this post in threaded view
|

Re: Error after attempting SSL tutorial

michaelklishin
In reply to this post by nybras
2013/3/20 nybras <[hidden email]>
I've tried killing the processes using PS but still not working. What's beam
though?

This suggests it is running as root and you run kill w/o sudo.

BEAM is Erlang VM.
--
MK

http://github.com/michaelklishin
http://twitter.com/michaelklishin

_______________________________________________
rabbitmq-discuss mailing list
[hidden email]
https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
Reply | Threaded
Open this post in threaded view
|

Re: Error after attempting SSL tutorial

nybras
Yeah I've been killing the only rabbitmq process that ever exists with 'kill 203022' etc. I've seen no signs of BEAM.
Reply | Threaded
Open this post in threaded view
|

Re: Error after attempting SSL tutorial

Tim Watson-5
On 20 Mar 2013, at 09:40, nybras <[hidden email]> wrote:

> Yeah I've been killing the only rabbitmq process that ever exists with 'kill
> 203022' etc.

You might want to try -9 with that kill!?

> I've seen no signs of BEAM.
>

Then what are you killing!? If there is no beam/beam.smp process then the broker isn't running.

>
>
> --
> View this message in context: http://rabbitmq.1065348.n5.nabble.com/Error-after-attempting-SSL-tutorial-tp25565p25587.html
> Sent from the RabbitMQ mailing list archive at Nabble.com.
> _______________________________________________
> rabbitmq-discuss mailing list
> [hidden email]
> https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
_______________________________________________
rabbitmq-discuss mailing list
[hidden email]
https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
Reply | Threaded
Open this post in threaded view
|

Re: Error after attempting SSL tutorial

nybras
In reply to this post by nybras
Well whatever the problem was, after re-installing AGAIN it now works, thank god! This is my university final year project I'm working on, I was starting to freak out.

Thanks for your help anyways guys! cheers