intenal error when connecting from rabbitmq-c

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

intenal error when connecting from rabbitmq-c

Gotthard, Petr

Hello,

While the rabbitmq-c on one machine is fine, on another machine I’m getting ‘server connection error 541, message: INTERNAL_ERROR’ and the rabbitmq log contains the following entries:

 

 

=ERROR REPORT==== 22-Oct-2012::12:38:17 ===

AMQP connection <0.2315.0>, channel 1 - error:

{{badmatch,{undefined,<<40,17,97,112,112,108,105,99,97,116,105,111,110,47,

                        110,111,116,97,109>>}},

[{rabbit_framing_amqp_0_9_1,decode_properties,2},

  {rabbit_binary_parser,ensure_content_decoded,1},

  {rabbit_channel,handle_method,3},

  {rabbit_channel,handle_cast,2},

  {gen_server2,handle_msg,2},

  {proc_lib,init_p_do_apply,3}]}

 

 

=CRASH REPORT==== 22-Oct-2012::12:38:17 ===

  crasher:

    initial call: gen:init_it/6

    pid: <0.2327.0>

    registered_name: []

    exception exit: {{badmatch,

                         {undefined,

                             <<40,17,97,112,112,108,105,99,97,116,105,111,

                               110,47,110,111,116,97,109>>}},

                     [{rabbit_framing_amqp_0_9_1,decode_properties,2},

                      {rabbit_binary_parser,ensure_content_decoded,1},

                      {rabbit_channel,handle_method,3},

                      {rabbit_channel,handle_cast,2},

                      {gen_server2,handle_msg,2},

                      {proc_lib,init_p_do_apply,3}]}

      in function  gen_server2:terminate/3

    ancestors: [<0.2324.0>,<0.2322.0>,<0.2320.0>,rabbit_tcp_client_sup,

                  rabbit_sup,<0.114.0>]

    messages: []

    links: [<0.2324.0>]

    dictionary: [{{credit_to,<0.2323.0>},49},

                  {permission_cache,[{{resource,<<"demo">>,exchange,<<"ais">>},

                                      write}]}]

    trap_exit: true

    status: running

    heap_size: 987

    stack_size: 24

    reductions: 895

  neighbours:

 

 

 

Could you please help me to identify what could be wrong?

 

Thanks,

Petr


_______________________________________________
rabbitmq-discuss mailing list
[hidden email]
https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
Reply | Threaded
Open this post in threaded view
|

Re: intenal error when connecting from rabbitmq-c

Matthias Radestock-3
Petr,

On 22/10/12 11:52, Gotthard, Petr wrote:

> While the rabbitmq-c on one machine is fine, on another machine I’m
> getting ‘server connection error 541, message: INTERNAL_ERROR’ and the
> rabbitmq log contains the following entries:
>
> =ERROR REPORT==== 22-Oct-2012::12:38:17 ===
>
> AMQP connection <0.2315.0>, channel 1 - error:
>
> {{badmatch,{undefined,<<40,17,97,112,112,108,105,99,97,116,105,111,110,47,
>
>                          110,111,116,97,109>>}},
>
> [{rabbit_framing_amqp_0_9_1,decode_properties,2},

Looks like the basic.publish headers/properties are invalid. I suggest
you try sending a message without any headers/properties. If that works
then carefully check your code that is constructing the
amqp_basic_properties_t. In particularly, make sure that you are setting
the flags correctly. See e.g.
http://comments.gmane.org/gmane.comp.networking.rabbitmq.general/2717

Regards,

Matthias.
_______________________________________________
rabbitmq-discuss mailing list
[hidden email]
https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss